Autor Thema: Merging oc.se -> oc.de  (Gelesen 10258 mal)

Offline OlofL

  • Nano
  • **
  • Beiträge: 70
  • OC SE Team
Re: Merging oc.se -> oc.de
« Antwort #15 am: 30. Januar 2011, 22:31:09 »
Just a short update on this project: The list of remaining tasks is rapidly shrinking and we only have a couple of bigger issues left,  but since we want to do these with good quality it will be at least to the end of February until we are finished. At http://test.opencaching.se/ you can see the current state.

Offline mic@

  • Vereinsmitglied
  • Large
  • *
  • Beiträge: 6436
  • oc-only Verstecker
Re: Merging oc.se -> oc.de
« Antwort #16 am: 07. Februar 2011, 01:41:32 »
Zitat von: OlofL
At http://test.opencaching.se/ you can see the current state.
THX for the link. BTW, Xmas is over now  ;)

Offline OlofL

  • Nano
  • **
  • Beiträge: 70
  • OC SE Team
Re: Merging oc.se -> oc.de
« Antwort #17 am: 07. Februar 2011, 22:08:14 »
We might not release the real version until next christmas... but hopefully we will! Perhaps an easter bunny is the way to go?

Offline zaanhoeve

  • Nano
  • **
  • Beiträge: 24
    • Opencaching.NL
Re: Merging oc.se -> oc.de
« Antwort #18 am: 26. Februar 2011, 15:56:03 »
Hello

I did try to login the dev site at .se. Im registrated but can not sent my self a reminder with the Activation code.
Regards Kees

oc.nl

Offline OlofL

  • Nano
  • **
  • Beiträge: 70
  • OC SE Team
Re: Merging oc.se -> oc.de
« Antwort #19 am: 26. Februar 2011, 20:32:34 »
Hello

I did try to login the dev site at .se. Im registrated but can not sent my self a reminder with the Activation code.
Thank you for just finding a bug... It is probably not the bug you thought though...

All sending of mails outbound from the test-server is switched off to avoid false messages. Also, all the user accounts, caches and logs are removed and replaced with data from the real site periodically.

The bug you helped us find was instead that the site was setup to use the wrong node. I've now activated your account.

But please also register at the real site, otherwise your user account might be deleted already tomorrow.

It is not always clear what branch that is currently in use of the test site, but you are welcome to test and if you find errors, you may register them as new issues at the google code site mentioned above in this thread.

Offline Geodude_DK

  • Aktive User
  • *
  • Beiträge: 3
I'm almost up and running
« Antwort #20 am: 23. März 2011, 19:41:30 »
Just a short introduction of myself: I'm a professional developer and has been invited by OlofL to join this project. I do not expect to be able to contribute with anything to the upcoming release, but the sooner I get familiar with how the code and the database is built, the sooner I can contribute with something for future releases.

But enough about myself, and on to what I really wanted to say.

I've got git up and running on my MacBook Pro with GitX as a GUI frontend and the se2de-merge project cloned.

I've got PHP and MySQL up and running on a Windows Server 2008 with a clean database restored.

I had a minor problem with my PHP version not supporting getmxrr, but I found a workaround.

Finally I tried to configure the application but something went wrong because when I try to run it I get this message:
Zitat
Safari can’t open the page.
Too many redirects occurred trying to open “http://ocse.dev/htdocs/”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

Any ideas of what to do to fix this?

BTW If anyone wonder: ocse.dev is an internal domain on my network running on my Windows Server 2008 :meise:
Arne aka Geodude_DK


oliver

  • Gast
Re: I'm almost up and running
« Antwort #21 am: 23. März 2011, 21:21:25 »
Hi Geodude_DK,

please check $opt['page']['absolute_url'] setting in config2/settings.inc.php
(and $absolute_server_URI in lib/settings.inc.php)

This is used when the site redirects you.
However, i dont understand why its a "endless redirection" ...
... as far as i remember, there was no such case in the past.
If the config is incorrect you should get 404 ...

Of course, i never tried to run the source with windows.
The source is known to work with Redhat/CentOS.
(CentOS runs well in HyperV)

Kind regards,
Oliver

Offline Geodude_DK

  • Aktive User
  • *
  • Beiträge: 3
Re: Merging oc.se -> oc.de
« Antwort #22 am: 24. März 2011, 10:14:52 »
I did modify $opt['page']['absolute_url'] but hadn't noticed $absolute_server_URI :-[ However, modifying the latter don't fix the problem  :(

EDIT: I just realized that OS/X has a built in Apache server, so I'm probably going to be able to set up a complete development environment on my MacBook Pro  8)
« Letzte Änderung: 24. März 2011, 18:52:52 von Geodude_DK »
Arne aka Geodude_DK


Offline OlofL

  • Nano
  • **
  • Beiträge: 70
  • OC SE Team
Re: Merging oc.se -> oc.de
« Antwort #23 am: 24. März 2011, 20:14:07 »
I don't recognize the error either. Does it work with an empty index.html in the htdocs-root? Or an empty index.php?

I'm running dev-env on windows, but apache, not IIS. I've been running wamp-server the last 1½ year. The real server is running linux and apache, the test-server is running the same environment.

Please be careful when using windows as development envorinment to make sure all source code is utf-8 without BOM (byte order marker) and with unix-style line endings. That means you cannot use Notepad (as it creates DOS linefeeds and inserts BOM at the start of utf-8 encoding), but Notepad++ is excellent for the job.

Offline Geodude_DK

  • Aktive User
  • *
  • Beiträge: 3
Re: Merging oc.se -> oc.de
« Antwort #24 am: 24. März 2011, 20:44:24 »
I've got Apache, PHP and MySQL up and running under OS/X, and for a moment I even had phpMyAdmin running, but now I'm having some access problems :o

Anyway, disregard my questions about my Windows problems, as I'm now trying to get everything running under OS/X :P

EDIT: It seems that my access problems has something to do with virtual directories. I temporarily commented the include of httpd-vhosts.conf out in my httpd.conf, and now phpMyAdmin is running again :)

Well, I'm out of time for now, so I'll have to wait and see if I can figure out what's wrong. But it is most likely a more viable solution to run it all under OS/X than to run parts of it on my Windows Server.

EDIT #2: I figured out how to add a virtual directory, but now I got another problem. When I execute htdocs/index.php i get this error:

Zitat
Fatal error: Call to undefined function bindtextdomain() in /Users/amu/se2de-merge/code/htdocs/lib2/common.inc.php on line 170

I tried to figure out how I can install gettext (which bindtextdomain seems to be part of), and found a package which should install it - but I still get the error. Any suggestions on how I can remedy this?
« Letzte Änderung: 25. März 2011, 17:50:32 von Geodude_DK »
Arne aka Geodude_DK


Offline mic@

  • Vereinsmitglied
  • Large
  • *
  • Beiträge: 6436
  • oc-only Verstecker
Re: Merging oc.se -> oc.de
« Antwort #25 am: 24. Mai 2011, 07:00:39 »
Zitat von: OlofL
A subproject of the task to merge features of the two main source versions have started.
Big THANK YOU for starting this task... now the first results can be seen in germany.
We got the "personal cache note" feature adopted which originally comes from the polish code.
 :D :D :D :D :D :D :D :D

Offline mic@

  • Vereinsmitglied
  • Large
  • *
  • Beiträge: 6436
  • oc-only Verstecker
Re: Merging oc.se -> oc.de
« Antwort #26 am: 17. August 2011, 11:56:08 »
What is the latest news of the code-migration?
Is it finished? Could You start other projects [1] meanwhile?  :)


[1] http://forum.geocaching-network.com/index.php?topic=1482